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1. INTRODUCTION 
DeLoad is a simple and compact utility designed to integrate the operation of the 
dataTaker data logger onto your PC’s desktop. DeLoad greatly simplifies the 
downloading of data and the automation of operation of the logger particularly when 
unskilled operators are involved. When DeLoad has been configured it is simple matter to 
double click a particular logger’s ICON on the desktop and the data will be downloaded.  
In addition the dataTaker data logger can be programmed simply by dropping a text file 
containing a dataTaker program on to the ICON and the program is sent to the logger. 
 

2. SYSTEM REQUIREMENTS 
• Windows 98/NT/2000/XP 
• 15MB free hard disk space 
• dataTaker DT50, DT500, DT600 series data logger; or  
• dataTaker DT800 data logger. 

3. SETUP DELOAD 
• It is necessary to install DeLoad version 2.18 or 

above. The latest version can be downloaded free 
from www.datataker.com . 

• If upgrading from a previous version uninstall the 
old version first. 

• If the installation process requests that the install 
wants to overwrite old files select ‘No’. 

• Connect the loggers you are using to a serial port 
on your PC. 

• To run DeLoad on the PC go to 
Start/Programs/Datataker/DeLoad 

• When DeLoad runs the first time it will search all 
the available serial ports for any installed dataTaker 
data logger. 

 
 

• When the process is complete a panel showing a 
logger picture is displayed for each connected 
logger. 

• Select the ‘Unload Options’ Tab 
• Set the name of the logger in the Description field. 
• Select the schedules and the file format to be 

downloaded. 
• Amend the location of the saved file if required. 
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• In this example a CSV (comma separated file) has been selected which is 
appropriate for importing files into Excel and the ULAST option. Selecting the 
ULAST option will download only data not previously downloaded i.e. new data. 

 
 

The next step is to create an icon on the desktop which will 
automatically download your data simply by double clicking t
icon.  

he 

• Select the dataTaker Details tab 
• Click the ‘Create Icon’ button to create an icon on your 

desktop 
 
 

• Check the Unload/Program Box 
• Click OK 
• Notice an Icon is created on your desktop using 

the name previously given on the options page. A different 
name can be entered if required. 

• Back on the Options page select the Options Tab 
 
• Uncheck the box ‘Show messages during unload’ 
• Click OK 

 
This completes the setup 
 
This process provides us with an Icon on the desktop, when double 
clicked, the data from that logger will be downloaded. 
Alternatively a text file containing a dataTaker program can be 
dropped on the Icon the program will be sent to the logger. 
 
 
 
 
 

• To manually add additional loggers 
select the ‘Add’ button on the 
DeLoad options page. 

 
• Simply enter the type of 

dataTaker and the 
communication method etc.  

• You can check the 
communications to the 
logger by pressing the Test 
Button. 
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4. DELOAD MENUS 

4.1. DeLoad Options 
This panel allows the user to find, add, view and 
delete dataTakers in DeLoad. dataTakers appear 
in the list below. To view or edit load and unload 
settings for a dataTaker, either find it 
automatically using the Find button or add it 
manually using the Add button, then click on 
View.  

4.1.1. Port List  
Sets the Com Ports that 
will be searched when the 
Search button is clicked. I
you have trouble with 
certain Com Ports or only 
want DeLoad to search 
particular ports, edit the AvailablePorts setting in 
c:\program files\deload\options.ini. eg : 
AvailablePorts=0 allows all ports, 
AvailablePorts=134 will allow ports 1, 3 and 4.  

f 

4.1.2. Find Ports 
Com Ports on this computer are by default automatically 
registered with DeLoad each time it starts and when the Find 
button is clicked.  
To manually set the Com Ports which DeLoad checks, when it 
runs, uncheck this box and edit the AvailablePorts setting in c:\program 
files\deload\options.ini. eg: AvailablePorts=124 will make DeLoad check com ports 
1, 2 and 4 each time it runs. 

 

4.1.3. Find 
This button will delete all dataTakers previously found and will 
add those currently found connected to local Com Ports on this 
computer.  dataTakers added manually will not be removed.  

 

4.1.4.  Add 
To add dataTakers connected via a modem or via Ethernet click on 
the Add button.  dataTakers connected to local com ports can also be 
manually added using this button.  
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4.1.5. DataTaker List 
This list shows all the dataTakers that 
have been registered with DeLoad. 

4.1.6. Delete 
Click this button to delete a dataTaker from the list.  No Data or 
programs are deleted, and the dataTaker can be re-added at any time. 

4.1.7. View 
Click this to view and edit load and unload options for each 
dataTaker in the list. 

4.1.8. Unload 
Click this to unload all data from all dataTakers in the above list as 
per settings in the unload options control panel for each dataTaker. 

4.1.9. Terminal 
This button can be used to send programs to the dataTaker. 
Click this button to bring up a terminal connected to the current 
dataTaker in the list.  Enter the program text to be sent to the 
dataTaker in the transmit window.  
Hit the Enter key to send the current line,  
Shift Enter - to create a new line  
Control c  - to copy  Control v  - to paste 
Alt a  - to send all text in the transmit window  
Alt Backspace - to delete all text in the current window. 
Double click to bring back a maximised window.  
Text sent back by the dataTaker appears in the receive window. 

Page 4 

4.2. Email 
DeLoad can be used to send downloaded data 
to one or multiple email addresses.  
This panel allows the user to configure login 
and account settings for an SMTP mail server. 
To use to send email with attached data from 
dataTakers configured for DeLoad.  The mail 
settings are global and apply to all dataTakers
Your computer either must be part of the sa
DNS domain as the SMPT server, 
alternatively an account set up on the server 
and the user name and password known to 
access the account.  

. 
me 
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4.2.1. Server Name 
Type in the DNS name or IP 
address of the SMTP server 
that’s to be used to send 
emails. 

4.3. TCP Port 
This is the TCP port number for the SMTP server. The 
standard port number for SMTP servers is 25. 

4.3.1. Server Requires Authority 
If your computer is not part of the same DNS domain as 
the SMTP mail server you want to use, you must click 
this box to enable STMP authentication.  Most SMTP 
servers will not allow open relaying of SMTP messages, 
and so it is necessary provide a user account name and password. 
 

4.3.2. Authentication Type Login 
At present, DeLoad only supports LOGIN authentication, so choose this option. The 
SMTP server specified in the "Server Name" box must also support LOGIN 
authentication. 
 

4.3.3. Email Test 
Click this button to check that you can login to the 
SMTP server you have chosen. This test must pass on 
the computer that will be running DeLoad to enable 
data to be sent via email. 

4.3.4. Sender 
Typ ress to 

n 

4.3.5. Account Name 
Typ  

 

4.3.6. Password 
Type in the password for the 

e in the email add
appear in the "From" header i
sent emails. 

e in the account name. This

  Page 5 

account must exist on the SMTP
server.  

account. 
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4.3.7. Site ID 
Text typed in here will appear in 
the subject and body of all emails 

.4. FTP 
a ws you to configure login 
c ttings for an FTP server to 

e 
ser name 

4.4.1. FTP Server Name 
Type in he
IP a

4.4.2. FTP User Name 
The accoun
serv  

3. FTP Password 
Type in the password for the FTP 
acc

 FTP SiteID 
Text type in here will be used as 
the t will be 

h 

  Page 6 

sent by DeLoad. 
 

4
This p nel allo
and ac ount se
use to send data from dataTakers to a 
remote FTP site. FTP settings are global 
and apply to all dataTakers. It is 
necessary to have an account set up on th
remote FTP server and with the u
and password for that account.  
 
 
 
 
 
 
 
 

re the DNS name or 
ddress of the FTP server to 

be used to use to send data to. 
 
 

t name for the FTP 
er must be entered here. The

account must exist on the FTP 
server. 

4.4.

ount. 

4.4.4.

name of a directory tha
created on the FTP server in whic
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data being sent will be saved. Spaces will be removed. 

4.4.5. FTP Test 
Click this button to check that the 

ill 
 

4.5. Options 
a e various options to be 

 

4.5.1. Show DeLoad Form 
Tic

4.5.2. Unload Data when DeLoad 

Tick this box if you want DeLoad to 
en 

 

4.5.3.  Unload everything 
Wh

 com 

ers 
 box is unticked, you must either click the Find 

 

be sent 

login to the FTP server that has 
been chosen correctly. This test 
must pass on the computer that w
be running DeLoad to enable data to
via FTP. 

This p nel allows th
set allowing the way DeLoad runs when it is
unloading data from a dataTaker.  

k this box if 
DeLoad to be 
visible on the 
desktop when 
started. 

Starts 

automatically start unloading data wh
started. If unticked, the Unload button on
the DeLoad form must be clicked to 
unload data. 

en this box is ticked DeLoad 
will be configured to find all 
dataTakers connected to local
ports on this computer and will 
unload all data from all dataTak
to c:\datataker\unloadall.  When this
button to automatically find dataTakers connected to this computer, or click the Add
button to manually add dataTakers.  DeLoad will then unload data from dataTakers 
in the list as specified in the edit panel for each dataTaker. Click the Edit button to 
view and change unload settings for each dataTaker. 
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4.5.4. Show unload 
directory 

Wh ory 
in which data is being saved to is 

 data in files on 
the 
directory chosen in the Edit panel for 

4.5.6. Desktop Directory 
Ent ill create and 

i

ta 

edn 

In t  or datetimen.txt where datetime is the 
date nal Settings control panel of the 

dul

wil  
unl Load 

xit after unload 
If this box is ticked DeLoad will close down 
whe s bee

 errors occur and when unloading 
has finished. Make sure this box is unticked if 
you want DeLoad to run automatically using a 
scheduler. 

en this box is ticked the direct

made visible on the desktop. 

4.5.5. Copy to desktop 
Tick this box to save

desktop in addition to the 

each dataTaker. 

er in here the name of a directory on the desktop which DeLoad w
save data to.  If this is left blank, data w

4.5.7. Append unloaded da
If this box is ticked, data is appended 
by schedule to files named sch
where n is the dataTaker schedule. If 
unticked, data is saved to separate files 
by schedule each time data is unloaded. 

ll be saved to  files on the desktop. 

to the last saved file 

his case the files are named datetimen.csv
 and time in the format as set in the Regio

computer, and n is the dataTaker sche

4.5.8. Hide DeLoad after unlo
If this box is ticked the DeLoad form 

e. 

ad 

l be hidden after data has been
oaded from all dataTakers. De

will still be running in the background. 

4.5.9. E

n data ha n unloaded from all 
dataTakers. 

4.5.10. Show Messages 
When this box is ticked DeLoad will pop up 
messages if

UM-0084-A0  Page 8 
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4.5.11. Lock 
Lock the Find, Add and Delete buttons to 
make it harder to accidentally modify or 
remove existing dataTakers. 

4.6. Logger Configuration 

4.6.1. DataTaker Details 

4.6.1.1. Set Com 
Click to 
select the 
method by 
which 
DeLoad will communicate with 
the dataTaker, and to edit 
communications settings. 

4.6.1.2. Create Icon 
Click t
butto
create an 
icon for 
this dataT
Icon can be used for the followi

his 
n to 

aker on the desktop.  
ng 

ata from a 

- ram to a 

- and to a 

Simply double click an icon on the desktop to unload data for this dataTaker.  

functions :- 
- Download d

dataTaker. 
Send a prog
dataTaker. 
Send a comm
dataTaker. 

Alternatively a program can be sent to the dataTaker by dragging the program onto 
the icon. Note that Options control panel must be closed when dragging a file to an 
icon. Double clicking on a command icon sends the set command to the dataTaker. 

UM-0084-A0  Page 9 
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4.7. Load Options 
 

4.7.1. Send Program to 
dataTaker 

4.7.1.1. Pr
end a 
e 

ogram 
Click this to s
program to th

nge of dataTakers, 
e 

e 

rrors. 
to a 

Click this to delete any current 
program

4.7.2. Send Program 
to Memory Card 

4 ard 
Click this to send a program to a memory card plugged in to the 
dataTa p  run the card program once it has 

cked 

sto
hen a card is plugged in. 

 Clear programs on a memory card plugged in to the dataTaker. 
 

 

dataTaker.  
Note that for 
DT50/500 ra
existing programs and data must b
deleted first before new programs ar
sent. You will be prompted to delete 
programs and data if necessary. 
Programs sent are checked for correct 
dataTaker language syntax and e
You can also drag a program on
shortcut for a dataTaker to send it. 

4.7.1.2. Clear 

s in the dataTaker. 
 

.7.2.1. Program C

red 

ker.  An o tion will be given to
been sent to the card.  Programs sent to memory cards are not che
for errors.  To check for errors send the program to the dataTaker first 
and then delete it and send it to the card.   
Note that for DT800 dataTakers this option is unavailable as programs 
internally are automatically synchronized w

4.7.2.2. Clear Card 
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4.7.3. Send Program to Flash Ram 

4.7.3.1. Program Flash 
Send a pro   Note that 
for ust be reset 
which means that 
deleted dataTaker if 

ge dataTakers, the dataTaker must be 
reset w s ms and data will be 
deleted t e dataTaker if 

Schedules 

schedule is specified when 
crea a 

n 

 

le. 

 
t

re crea

 
ata will not downloaded again.  

for the schedule will be unloaded each tim

gram to the dataTakers internal Flash.
DT50/500 range dataTakers, the dataTaker m

all existing programs and data will be 
.  A prompt will be given to reset the 

necessary.  Programs sent to Flash are not checked for 
errors. To check for errors send the program to the dataTaker f
and send it to Flash. 

4.7.3.2. Load Flash Clear 
Clear the user program area of Flash in the dataTaker.  Note 
that for DT50/500 ran

irst and then delete it 

hich mean  that all existing progra
. A promp  will be given to reset th

necessary. 

4.8. UnLoad Options  

4.8.1. 
dataTakers store data 
internally by schedule.  A 

ting the program that 
dataTaker will run whe
making measurements and 
logging data. Similarly, data
is unloaded by DeLoad to 
files by dataTaker schedu
Tick the boxes for the 
schedules you want data to 
be unloaded for. If you tick
a box and there is no data for 
schedule then no files a
schedule. 

4.8.2. ULAST 
If this box is ticked, only new data will be
unloaded d

hat 
ted for that 

unloaded ie previously 
If un-ticked, all data 

e. 

UM-0084-A0  Page 11 



DeLoad User’s Manual      

4.8.3. CSV 
It this box is ticked, data will be unloaded from the dataTaker and saved 
to a file in comma separated values CSV format.  If un-ticked, data will 
be saved to a file in the native dataTaker formatted text 
mode format. 

4.8.4. HTML 
If this box is ticked, data will be copied to files in the 
dataTaker directory in a directory named HTML, in 
HTML format. 

4.8.5. Records 
This option specifies how many records back from the end 
of logged data will be saved to file in HTML format. Use 
this setting in conjunction with the rate of sampling set for 
the schedule (in the dataTaker program) and the rate at 
which DeLoad unloads data from the dataTaker, when  
DeLoad is run regularly using a scheduler. The effect is a 
sliding window of data that can be imported into Excel and 
used to update a graph in real time 

4.8.6. Description 
All data unloaded from a dataTaker by DeLoad is 
saved to directories created in a master directory 
specified in the "Save Unload to Disk" setting 
below.  Each dataTaker gets its own directory 
under the master directory.  Text typed in here will 
be used as the name of that directory.  The text also appears in emails sent by DeLoad 
and is used as the name of a directory that will be created on the FTP server (if used). 
It this field is left blank, data is saved to disk in a directory named 
comportn/datatakermodel or ip_address/datatakermodel, under the master directory. 
If you want to use the windows scheduler to run DeLoad, specifying c:\program 
files\deload\deload.exe will unload all data from a dataTaker with schedules ticked.  
If you only want to unload data from individual dataTakers, use what you type in the 
description box as an argument to deload.exe eg: 'c:\program files\delolad\deload.exe 
TEST'.  This will only unload data from the logger with the description 'TEST'. In 
this way you can unload data from specific dataTakers at different times. 

4.8.7. SaveTo Disk 
Allows you to choose a disk or network path other 
than the default under which to store directories and 
unloaded data. 
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4.8.8. Edit 
Click this to change the path of the master directory 
under which data for this dataTaker will be saved. 

4.8.9. Master Directory 
This is the master directory where all data for this dataTaker will 
be saved. To change the path, click the Edit button. 

4.8.10. Unload to an Access database 
 If this is ticked data unloaded from the dataTaker will be added to an Access 2000 
database called description.mdb. The database is saved in the master unload directory. 

4.8.11. Edit Access database 
Click this button to edit the names of tables that will be 
created in the database, one table per dataTaker schedule. 

4.8.12. Send Via Email 
Tick this box and DeLoad will send data as an attachment to 
an email.  Make sure that the configured and tested the settings under the Email  tab 
on the Options control panel. 

4.8.13. Edit List 
Click to edit the email addresses that dataTaker Schedules are to 
be sent to. There is a limit of 20 email addresses per schedule. 

4.8.14. Send Via FTP 
Tick this box if DeLoad is to send data to an ftp server.  

Click this button to unload data for this dataTaker now 

n 
Clic tton to  run after data 

4.8.17. Unload Send 
Clic tton to  be sent to the 

Ensure the settings under the FTP tab on the Options 
control panel are correctly configured and tested. 

4.8.15. Unload 

as per the settings in this panel. 

4.8.16. Unload Ru
k this bu  set a program to

has been unloaded for this dataTaker. 
 

k this bu  set a command to
dataTaker immediately after all data has been 
unloaded.  The command must be a valid dataTaker 
command. 

UM-0084-A0  Page 13 
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5. 
eLoad utility 

rogram the logger 
If y e  
clic

e temperature of a therm
annel one every 5 seconds 

hen click File>Save 
rag the ICON of the file you have just 

created and drop it on your logger ICON.  This program
the logger. 

rogram will be sent to the logger 
ram 

as been

APPLICATIONS USING DELOAD 

ocouple on 

The followings are examples of applications using the D
program for dataTaker data loggers. 

5.1. Using the ICON to p
ou hav  a dataTaker logger program use that, otherwise right
k on the desktop and select New>Text Document 

Give the file an appropriate name. 
Double Click on the file and add the following text 

 
This program will record th
ch
 
 

 will then be sent to 

 
 
 
 
T
D

A series of screens appear followed by a warning screen 
Click Yes and the p
If there is already data on the logger from a previous prog
a second warning screen will appear.  
Click Yes to continue 
The logger will indicate the program h  loaded 
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5.2. Using the ICON for getting data from the logger 
Simply double click on the ICON.  The PC will then locate the logger and download the 
most recent data and place it in directory specified 

 
 

 
 
 
 
 
 
 
 
 
 
 
 
The file is in CSV format as specified.  If you double click on the file if you have Excel 
loaded it will open in Excel.  
Note:  

• Right clicking on the file and selecting the rename option can change the name of 
the file. 

• The name of the file consists of the date and time of the download. For example 
the above filename used is 310304121103A is on the 31/03/04 at 12:11:03 
schedule A was downloaded 

 
Using the above procedure an ICON for each logger is created.  The operator then simply 
double clicks on the ICON or selects it and presses the enter key to download the data 
from each logger.  If program changes need to be done the operator simply drops the 
updated program on the appropriate ICON after the download is completed.  This will 
reprogram the logger. 
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5.3.  You want to automatically download data from a logger 
connected via an Ethernet port once per day and email the 
downloaded files 

For this setup we have a DT800 connected to the same network at the PC on IP address 
169.254.0.10 port 8. The program has already been loaded in the logger. 

5.3.1. Run DeLoad Options 
• Click Start>Programs>DataTaker>Deload Options 

Page 16 

 
 

• When The DeLoad Options Screen has loaded click Add 
• Set the appropriate type of logger  
• If it is a DT800 enter the Serial Number (Its on the 

back of the logger) 
• IP address and Port Number (Always 8 for a DT800) 

 
Press Test to confirm the logger can be found 

• Click OK 
 
 
 
 
 

• This will take us to the logger configuration page 
• Click the Unload Options Tab and select the Schedules which are to 

be downloaded 
 

• Click Edit List to specify the email addresses you want 
the data sent to. 

 
 
 
 

• Click OK  
• Select the dataTaker Details TAB and click the 

Create Icon button 
• Click Unload/Program 
• Click OK  
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• On the DeLoad Options page select the email tab and enter 

the appropriate information for your mail server (you may 
need to get some of this information from you network 
administrator)  

 
 
 

• Select the options page and uncheck the ‘Show messages 
during unload” option 

• Click OK 
 
 
To test the DeLoad setup, double click on the ICON on the desktop. Data should be 
downloaded and emailed 
 
 

5.3.2. Setup Windows scheduler 
 
 
 

• Open the control Panel on the computer and 
select the ‘Scheduled Tasks’ Icon 

 
• Drag the DeLoad ICON onto the scheduler 

 
• Double click to open the properties box 

 
• Click Set password and set your windows 

logon password 
 

• Select the Schedule Tab 
 

• Note how you can set the time at which y
want this task to run.  

ou 

 
• Click OK and close the scheduler 

 
• The task will now run at the rate you have 

set. 
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5.4.  We want to download every 1 minute from an attached 
logger and ftp the information to a web site, then use 
Excel to graph the information at a 1min update rate.  

5.4.1. Setup DeLoad 
• Select The Deload Options from the 

menu 

Page 18 

• Select the FTP tab 
• Enter the Server Name (address) 
• The User Name 
• The Password 
• Also a Site ID name 
• You can check the configuration be 

pressing the ‘Test Login’ button 
• Select the dataTakers TAB 
• Click Find to begin searching 
• The program will then search every available 

communications port at every available 
communications rate to try and determine the 
presence of each dataTaker Logger connected 
to the logger 

 
• When the process is complete a panel is displayed 

for each attached logger 
Select the ‘Unload Options’ Tab 

• Select the schedule to download 
• Select HTML 
• Set the number of records in the HTML file. In 

this case because we are sampling at 5 second 
intervals 720 samples will provide us with the 
last hour of data 

• Also check the ‘Send via FTP’ 
• Select the ‘dataTaker Details’ tab and check the 

Create Icon button 
• Click OK on the logger page 
• Select the Options TAB 
• Check: Append Unloaded data to last saved file. 

This options means you have only one CSV 
backup file instead of many 

• Uncheck: Show messages during unload. 
• Click OK to close Deload Options 
• We then double click on the ICON we have now created on the 

desktop 
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• The following sequence occurs 
o It looks for the logger 
o Locates the logger 
o Determines what needs to be downloaded 
o Downloads the data 
o Converts the data to CSV 
o Converts the data to HTML & removes the 

‘excess’ records from the file (i.e. we are limiting 
the size of the HTML file using the 720 records 
selection) 

o The HTML file is than sent via FTP 

5.4.2. Configure Excel 
• Run Excel and select Data>Get 

External Data>New Web Query 
 
 
 
 
 
 

• Click the Browse Web button 
 
 
• Browse to the site you have used in 

your FTP 
 
Note: that the directory used for the FTP is 
the Name used in ‘Site ID’ but with illegal 
characters removed and the subdirectory is 
the logger description field. 

• Close the browser when the file is visible. 
 

 
 

• Click OK 
 

• Select Properties 
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• Set Enable background refresh 

e external data from worksheet 
before saving 

mulas in columns adjacent 
to dataTaker 

 
• 

 
• 

ghlight the appropriate 
columns and form a graph. Excel will check 
for changes to the A.htm file every minute. 
The Excel file with the remo
where. The final task is to get DeLoad to update the A.htm
1 min. We do this using the Windows Scheduler 

 
 
 

 

p Windows scheduler 

and double click on the ‘Scheduled Tasks’ 

 
• 

 
• 

• Sel
 

• Clic

• Set Refresh to 1 min 
• Set Refresh data on file open 
• Set Remov

• Set Fill down for

• Click OK 

Click OK again 

The data is imported into the Excel 
spreadsheet. If you hi

te link can be placed on ANY PC ANY 
 file every 

 
 
 
 
 

 

5.4.3. Setu
 

• Open the control Panel on the computer 

Icon 
 

• Drag the DeLoad ICON onto the scheduler 

Double click to open the properties box 

Click Set password and set your windows 
logon password 

 
ect the Schedule Tab 

k the Advanced.. button 

UM-0084-A0  Page 20 



DeLoad User’s Manual      

 
o Set ‘Every’ to one minute 
o Set ‘Duration’ to 24hrs 

 
• 

• The DeLoad will now download ALL the loggers in its list every minute. The 

 

un different 
loggers at different rates 

• Right click on the Logger ICON you want to autom
t

 

 
• Open the control Panel on the computer and 

 
• Double click on this task to open the properties box 

 
• Type Ctrl-V to paste the ‘Target Name’ into the ‘Run’ 

 
• Select the Schedule TAB 

 

 
 

• Click OK and close the scheduler. Only the selected 
logger will now run at that rate. You can now using a 
similar technique add additional loggers at different 
rates. 

 
 

o Check ‘If the task…’ 
 

• Click OK 

Click OK and close the scheduler 
 

FTP the data to a web site. The data can then be observed using Excel on ANY 
PC with access to the web site at a 1min update rate. 

5.5. How do we set the Windows scheduler to r

ate and select properties 
rl-C. Click OK • Select the ‘Target Name’ and copy it using C

 

select the ‘Scheduled Tasks’ Icon 
 

• Click File>New>Scheduled Task 
 

• Give the task an appropriate name 

Box 

 
• Note how you can set the time at which you want this

task to run.  
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. How do we pe

 

5.6 rmanently record a pro
ory using DeLoad. 

 
•  had a 

cted OR use the drop down box and 

• 
• program. In this 

instance we want to flash the program
Program Button in the Flash area 

 

gram into a 
dataTakers mem

• Run DeLoad Options 

Either Click Find if you have not previously
logger conne
select the logger that you want to program. 

• Click View 
Select the ‘Load Options’ Tab 
Select where you want to load the 

. Select the 

 
• Deload will search for the connected logger 
• Select the appropriate program to transmit. 
• You are given a warning 

 
 

• n 
completed. If there is a syntax error in the 
program you are given a warning. 

 

5.7  
ashed into a 

 

 
•  had a 

cted OR use the drop down box and 
to program. 

 
 
 

Then confirmation the task has bee

. How do we delete a program
 flwhich has been

loggers memory
• Run DeLoad Options 

Either Click Find if you have not previously
logger conne
select the logger that you want 

• Click View 
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• Select the ‘Load Options’ Tab 
• Select where you want to delete the program from 
• Click the appropriate Clear Button 

 
 

• Deload will search for the connected logger 
• Give you are warning and then clear the program

 
 

 we save data to an Access 

• 
er the ‘Find’ , 

 Setup panel is visible 
• Sel
• You

o 
o is is only 

 file) 
ck Save to .mdb (this is not available 

• 
es entered here are the names used for 

ataTaker Details TAB 
utton 

• (You ma

 

is in this case ‘GenNo1’ and the 

  

5.8. How do
database. 

Run Deload 
• Create a connection to a logger using eith

‘Add’ or ‘View’ buttons 
• When the Logger

ect the Unload Options Tab 
 need to set 

A schedule to be downloaded 
Usually check ULAST (th
download data which has NOT been 
downloaded previously) 

o Set the Description (This is also the name 
used for the Access database

o Che
until a description is given) 

Click Edit 
• These nam

the Access database tables 
• Click OK 
• Click the d
• Click the Create ICON b
• Click OK 
• Select the Options Tab 
• Check ‘Append unloaded data to…’ 
• Uncheck ‘Show messages …’ 

y uncheck ‘Show unload…’) 

e 

• Click OK 
 
When the Desktop ICON is doubl
clicked and DeLoad is executed 
you will find an Access database 
created in the ‘unload directory’. 
The name of the Access database 
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database will have a table named ‘Daily’ which contains the downloaded data. 
 

 
 
 
 
 
 
 
 

5.9. If DeLoad does not show the appropriate 
communications ports. 

• When DeLoad first runs it identifies the 
communications ports your PC has. If 
you subsequently add communications 
ports then these are not available on the 
DeLoad menu. To solve this problem 
you need to edit the ‘Options.ini’ file in 
the DeLoad install directory (usually 
C:|Program Files\DeLoad) 

• Change the AvailablePorts= listing to include the 
communications ports you require. 

• You will need to delete the ICONS for each logger  
• ‘View’ each logger in the DeLoad options panel.  
• Click “Set Comm”  

 
 
 
 

• Click the ‘Test’ button to confirm they are still operating 
correctly 

• Click OK (else adjust the communications parameters) 
 
 

• Click ‘Create ICON’ for each logger.  
(DeLoad determines its reference to a particular logger by the position in 
the AvailablePorts string which a logger is referenced) 
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5.10. Setup Windows with customized file types, which, when 
double clicked are sent to a specific logger. 

This is useful when an unskilled operator is to select between different programs to be 
used on a different loggers. 
If we have three loggers Site1, Site2 & Site3 
We have a number of different programs that are to be used on the different sites. 

5.10.1. Create Icons on the desktop 
for the three different sites 

• Run ‘DeLoad Options’ 
• Select Add 
• Enter the appropriate type of dataTaker 

and communications port 
• Click OK 
• Select the Unload Options Tab 
• Select the appropriate schedules together 

with ULAST and CSV if appropriate for 
this project. 

• Set the Description to Site1 
• Click dataTaker Details Tab 
• Click Create Icon 
• Select Load/Unload option  
• Click OK 
• Repeat this process for the three different 

sites. Starting by clicking Add 
• When the three sites have been created 

Click OK to exit (note you can go to the options tab and set 
various options here depending upon your requirements 

• We should have the three logger icons on the desktop 
 
 
 
 
 
 

5.10.2. Create a directory which is to contain the programs 
on the desktop  

• Right Click on the desktop 
• Select New>Folder 
• Enter an appropriate name 
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• Double Click on the Icon to open the 
folder 

Page 26 

 
• Select Tools>Folder Options 

 
• Select the ‘File Types’ tab 

 
• Click New 

 
• Enter the first file type 

 
• Click OK 

 
• Select the newly created type and Click 

‘Advanced’ 
 

• Click New 
 

• Enter Edit and Click Browse 
 

• Browse to C:\Windows\System32 
 

• And select Notepad.exe 
 

• Click Open 
 

• Add ‘%1’ to the ‘Application 
used..’ text 

 
• Click OK 

 
• Click New 

 
• Enter ‘Send to dataTaker’ 

 
• Select the Site1 Icon on the desktop 

 
• Right Click and Select Properties 

 
• Highlight the ‘Target’ line and Type Ctrl-C 

 
• Then click Cancel 

 
• Return to the New Action and Type Ctrl-V to 

paste this line 
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• Add %1 to the end of the line 
• Click OK.  
• Highlight and Select Set Default for the 

action which will be executed by ‘Double 
Clicking’ 

• Click Change Icon 
• Select an appropriate Icon 
• Click OK 
• Click OK 
• Repeat this process for each site 

 
• Note %1 is added to all of the 

‘Application used to…’ lines 
 

• Click Close to finish 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

5.10.3. Create a program for a 
specific logger. 

• Right Click in the Blank area of the page and select 
New>Text Document.txt 

• Enter the name  
• ‘Program Number 1.Site1’ 
• The system will display a 

warning Answer Yes 
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We now have a text file which when we double click it will be transmitted to the 
appropriate logger and if we right click we have an edit option available which will open 
the file using notepad. 

 
We would copy the appropriate text into this file.  We then end up with an arrangement 
that is very obvious.  If you check the Internet you can find many different Icons 
available.  Also Icon editors are available so you can use customized icons. 
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5.11. Setting an ICON to execute a dataTaker command 
• Run ‘DeLoad Options’ 

 
• I am going to setup some ICON for a Connection which I have previously called 

WeatherStation. 
• Click the ‘View’ Button 
•  
•  
•  
•  
• Click the ‘Create Icon’ button 

 
 
 
 
 

• Enter any command required. For Example H will halt the 
logger 

• If you want the terminal window to remain open after the 
command has been sent check the ‘Show Terminal’ Box 

 
 
 

5.11.1. Other possible commands are their uses 
Here are some examples of the type of commands that can be used in this way 
Command Result 
H Halts logger operation 
CLEAR LOGON Clears all stored data in the logger. It then transmits Note this is 

potential quite dangerous to have available to an unskilled 
operator.  If DeLoad uses a ULAST option then this command is 
unnecessary 

STATUS This will display the loggers status in the terminal window and 
leave the terminal window open. 

RA1S Will change the loggers recording rate to 1S 
1DSO=1 This will set digital output to 1 
1..10TK This would display 10 type K thermocouple measurements 
X This would execute the X schedule and leave the window open 
 


	INTRODUCTION
	SYSTEM REQUIREMENTS
	SETUP DELOAD
	DELOAD MENUS
	DeLoad Options
	Port List
	Find Ports
	Find
	Add
	DataTaker List
	Delete
	View
	Unload
	Terminal

	Email
	Server Name

	TCP Port
	Server Requires Authority
	Authentication Type Login
	Email Test
	Sender
	Account Name
	Password
	Site ID

	FTP
	FTP Server Name
	FTP User Name
	FTP Password
	FTP SiteID
	FTP Test

	Options
	Show DeLoad Form
	Unload Data when DeLoad Starts
	Unload everything
	Show unload directory
	Copy to desktop
	Desktop Directory
	Append unloaded data to the last saved file
	Hide DeLoad after unload
	Exit after unload
	Show Messages
	Lock

	Logger Configuration
	DataTaker Details
	Set Com
	Create Icon


	Load Options
	Send Program to dataTaker
	Program
	Clear

	Send Program to Memory Card
	Program Card
	Clear Card

	Send Program to Flash Ram
	Program Flash
	Load Flash Clear


	UnLoad Options
	Schedules
	ULAST
	CSV
	HTML
	Records
	Description
	SaveTo Disk
	Edit
	Master Directory
	Unload to an Access database
	Edit Access database
	Send Via Email
	Edit List
	Send Via FTP
	Unload
	Unload Run
	Unload Send


	APPLICATIONS USING DELOAD
	Using the ICON to program the logger
	Using the ICON for getting data from the logger
	You want to automatically download data from a logger connected via an Ethernet port once per day and email the downloaded files
	Run DeLoad Options
	Setup Windows scheduler

	We want to download every 1 minute from an attached logger and ftp the information to a web site, then use Excel to graph the information at a 1min update rate.
	Setup DeLoad
	Configure Excel
	Setup Windows scheduler

	How do we set the Windows scheduler to run different loggers at different rates
	How do we permanently record a program into a dataTakers memory using DeLoad.
	How do we delete a program which has been flashed into a loggers memory
	How do we save data to an Access database.
	If DeLoad does not show the appropriate communications ports.
	Setup Windows with customized file types, which, when double clicked are sent to a specific logger.
	Create Icons on the desktop for the three different sites
	Create a directory which is to contain the programs on the desktop
	Create a program for a specific logger.

	Setting an ICON to execute a dataTaker command
	Other possible commands are their uses



